$re = '/(?<!^).(?=.*?.@)/m';
$str = 'example@gmail.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;