$re = '/([\d\.]+)\s(\S*)\s(\S*)\s\[(.*?)\]\s"(.*?)"\s(\d+)\s(\S*)/';
$str = '10.223.157.186 - - [15/Jul/2009:15:50:37 -0700] "GET /assets/swf/home-media-block.swf HTTP/1.1" 200 123884';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);