re = /^.*(?<!world\.)$/m
str = 'Hello, world.
Hello, world
Hello, world.
^ Spaces added ^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end