import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\nw].{5}|.[^\\no].{4}|.{2}[^\\nr].{3}|.{3}[^\\nl].{2}|.{4}[^\\nd].|.{5}[^\\n.]$|^.{0,5})$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "Hello, world.\n"
+ "Hello, world\n"
+ "Hello, world. \n"
+ " ^ Spaces added ^";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}