Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.]$|^.{0,5})$
/
gm
Input 1
1
New
1 12 123 1234 12345 123456 Hello, world. Hello, world Hello, world. ^ Spaces added ^