$re = '/^(?!.*foo).*$/m';
$str = 'Text with foo here
foo Text
More foo
Match this line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);