#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?!^count$|^find$).+"
Local $sString = "sku" & @CRLF & _
"count" & @CRLF & _
"find" & @CRLF & _
"countfind" & @CRLF & _
"findcount" & @CRLF & _
"skucount" & @CRLF & _
"skufind" & @CRLF & _
"countsku" & @CRLF & _
"findsku" & @CRLF & _
"coun" & @CRLF & _
"fin" & @CRLF & _
"ount" & @CRLF & _
"ind" & @CRLF & _
"skucoun" & @CRLF & _
"skufin" & @CRLF & _
"finsku" & @CRLF & _
"counsku"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")