re = /^(?!foo$).*$/m
str = 'Not:
foo
But:
Text with foo hereee
foo Text
More foo
foo
^ whitespace ^
1
12
Match this line
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end