import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}\\s*年\\s*\\d{1,2}\\s*月\\s*\\d{1,2}\\s*日)";
final String string = "1959年12月16日 (昭和34年)\n"
+ "1959 年12月16日 (昭和34年)\n"
+ "1959 年 12 月 16 日 (昭和34年)\n"
+ "1959 年 12 月 16 日 (昭和34年)\n"
+ "1959 年12 月 16日 (昭和34年)\n"
+ "1959 年 12 月 16 日(昭和34年)\n"
+ "1959 年 1 月 1 日(昭和34年)\n"
+ "1959 年 12 月 1 日(昭和34年)\n"
+ "1959 年 1 月 16 日(昭和34年)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}