use strict;
my $str = '1959年12月16日 (昭和34年)
1959 年12月16日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年12 月 16日 (昭和34年)
1959 年 12 月 16 日(昭和34年)
1959 年 1 月 1 日(昭和34年)
1959 年 12 月 1 日(昭和34年)
1959 年 1 月 16 日(昭和34年)';
my $regex = qr/(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}