import re
regex = re.compile(r"(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)", flags=re.MULTILINE)
test_str = ("1959年12月16日 (昭和34年)\n"
"1959 年12月16日 (昭和34年)\n"
"1959 年 12 月 16 日 (昭和34年)\n"
"1959 年 12 月 16 日 (昭和34年)\n"
"1959 年12 月 16日 (昭和34年)\n"
"1959 年 12 月 16 日(昭和34年)\n"
"1959 年 1 月 1 日(昭和34年)\n"
"1959 年 12 月 1 日(昭和34年)\n"
"1959 年 1 月 16 日(昭和34年)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")