import Foundation
let pattern = #"\/cue\/(?<Name>(?:LIGHT|PAR|EFFECT|EFFECT_S|VIDEO))\/((?<Group>([0-9oe,-]+|(?:ALL)))\/(?<Point>([0-9oe,-]+|(?:ALL)))\/(?<Brightness>([0-9,]+))\/(?<Time>([0-9]+))\/$|(?<PointP>([0-9oe,-]+|(?:ALL)))\/(?<BrightnessP>([0-9,]+))\/(?<TimeP>([0-9]+))\/$|(?<EffectName>(?:VIDEO|CUE|LIGHT_BALL|RAIN|SATURN_RING))\/((?<Weight>[0-9\-.]+)|(?<Parameters>([a-zA-Z0-9\-,{}=.;]+)))\/|(?<Contant>([a-zA-Z0-9\-\/._]+))\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/cue/LIGHT/10/10/255/0/
/cue/PAR/10/255/0/
/cue/EFFECT/VIDEO/1.8/
/cue/EFFECT_S/RAIN/{1,2,3,4,5,}/
/cue/VIDEO/PLAY/
/cue/VIDEO/TIME/0.5/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)