#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(^\/\*\*(.*?)\*\*\/)"
Local $sString = "/**" & @CRLF & _
"HI" & @CRLF & _
" **/" & @CRLF & _
"#define 1" & @CRLF & _
"/** Hi **/" & @CRLF & _
"/** Hi **/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")