import Foundation
let pattern = #"SomeData\n([-+]?[0-9\n]+[0-9,\n]*(?:\.[0-9\n]+)?[ \n]){6,6}SomeData"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SomeData
0.
00 0.00 10,
9
21,
594.89 -9,563,2
7
1
.
0
6
0
.
0
0
1
,
3
5
8,
3
23
.83
SomeData
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}