// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^#\r\n]+?)[^\S\r\n]*#").unwrap();
let string = "These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}