# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/ = NULL/igm;t' <<< "$a, $a, $a
$a, $a = '', $a
$a
$a,
$a = '', $a"