#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))"
Local $sString = "$a, $a, $a" & @CRLF & _
"$a, $a = '', $a" & @CRLF & _
"$a" & @CRLF & _
"$a," & @CRLF & _
"$a = '', $a"
Local $sSubst = " = NULL"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)