$re = '/(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/im';
$str = '$a, $a, $a
$a, $a = \'\', $a
$a
$a,
$a = \'\', $a';
$subst = " = NULL";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;