import Foundation
let pattern = #"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
$a, $a, $a
$a, $a = '', $a
$a
$a,
$a = '', $a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" = NULL"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)