// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)").unwrap();
let string = "<!--[TAG_START]-->a<!--[TAG_END]-->
<!--[TAG_START]-->b<!--[TAG_END]-->
<!--[TAG_START]-->c<!--[TAG_END]-->
<!--[TAG_START]-->d<!--[TAG_END]-->
<!--[TAG_START]-->e<!--[TAG_END]-->
";
let substitution = "f";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}