#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?"
Local $sString = "otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1" & @CRLF & _
"" & @CRLF & _
"otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15" & @CRLF & _
"" & @CRLF & _
"otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456" & @CRLF & _
"" & @CRLF & _
"otpauth://totp/fred?secret=2345678BCDC&issuer=Example"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")