using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?";
string input = @"otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1
otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15
otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456
otpauth://totp/fred?secret=2345678BCDC&issuer=Example";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}