import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "otpauth:\\/\\/([ht]otp)\\/(?:[a-zA-Z0-9%]+:)?([^\\?]+)\\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?";
final String string = "otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1\n\n"
+ "otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15\n\n"
+ "otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456\n\n"
+ "otpauth://totp/fred?secret=2345678BCDC&issuer=Example";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}