// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?").unwrap();
let string = "otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1
otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15
otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456
otpauth://totp/fred?secret=2345678BCDC&issuer=Example";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}