import Foundation
let pattern = #"(st=(\w+))?(&?c=(\w+))?(&t=(\w+))?(&k=(\w+))?( HTTP)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2,\4,\6,\8"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)