re = /(?=^[^\s]+(.*[^\s]+)*$)^[a-zA-Z0-9_{}#$\/\-\+@!?()^%$`~|:,.=\[\]\s]*$/
str = 'ttyt hgghghgh'
# Print the match result
str.match(re) do |match|
puts match.to_s
end