$re = '/<com\.mfs\.model\.connector\.ConnectorBrowseInfo>\n.+\n.+?<name>(.*?)<\/name>/m';
$str = '<com.mfs.model.connector.ConnectorBrowseInfo>
<type>css</type>
<name>Cascading Style Server</name>
<typeGroup>css</typeGroup>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);