$re = '/^(?:http(?:s)?:\/\/.*\/produtos-exclusivos\/)(.*?)\b(\/.*)?$/i';
$str = 'http://rogeriobonfim.local/produtos-exclusivos/245/sadf/sadf';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;