package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f]`)
var str = `?????????????☺️?????????????????????????????????????????????????????????`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}