Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f]
/
g
Input 1
1
New
?????????????☺️?????????????????????????????????????????????????????????