#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)([0-9]*\.?[0-9]*)\s*%"
Local $sString = "(x-10)+1.23 * 40.014 dd % something else" & @CRLF & _
"(x\1-0.3) + (y/1-.15)" & @CRLF & _
"(x\(1/30.011%) + (y/(1/15%)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")