using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]*\.?[0-9]*)\s*%";
string input = @"(x-10)+1.23 * 40.014 dd % something else
(x\1-0.3) + (y/1-.15)
(x\(1/30.011%) + (y/(1/15%)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}