// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([0-9]*\.?[0-9]*)\s*%").unwrap();
let string = "(x-10)+1.23 * 40.014 dd % something else
(x\\1-0.3) + (y/1-.15)
(x\\(1/30.011%) + (y/(1/15%)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}