$re = '/(?:|(?<!^)\G)\K([^ ]*)\s+/';
$str = 'asdas as das.mp3';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;