#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "b.*?apple(*SKIP)(*F)|apple"
Local $sString = ">Matched" & @CRLF & _
"dolphin elephant apple star" & @CRLF & _
"dog cat apple banana" & @CRLF & _
"" & @CRLF & _
">Unmatched" & @CRLF & _
"map banana apple dog" & @CRLF & _
"" & @CRLF & _
">Only the first apple matched, others are unmatched." & @CRLF & _
"map apple banana apple cat" & @CRLF & _
"map apple banana apple banana apple" & @CRLF & _
"" & @CRLF & _
">The first apple and the second apple matched, others are unmatched." & @CRLF & _
"map apple dog apple banana apple banana apple" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")