// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Building1-Lab1-.+$").unwrap();
let string = "Building1-Lab1-DeviceABC1
Building1-Lab1-DeviceABC2
Building1-Lab1-DeviceXYZ1
Building1-Lab2-DeviceABC1
Building1-Lab2-DeviceABC2
Building1-Lab2-DeviceXYZ1
Building2-Lab1-DeviceABC1
Building2-Lab1-DeviceABC2
Building2-Lab1-DeviceXYZ1
Building2-Lab2-DeviceABC1
Building2-Lab2-DeviceABC2
Building2-Lab2-DeviceXYZ1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}