using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[^>]+(?=<)";
string substitution = @"";
string input = @"<td colspan='2'><a>This is a Text in <b>Bold</b></a></td>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}