# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{link}{(.*?)}{(.*?)}{link}/<a href=\1>\2<\/a>/g;t' <<< "\"Customer office is responsible for this. Contact info can be found {link}{www.customerservice.com}{her!}{link} More info can be found {link}{www.customerservice.com/moreinfo}{her!}{link}\""