const regex = /([\w-]+[_][\w-]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w-]+[_][\\w-]*)', 'gm')
const str = `904-555-1212_Ramada-Holiday-opt2
foo ABC_TEMP_11_2011_09-02_9045551234-opt2 foo
foo abc_TEMP_11_2011_09-02_9045551234 foo
foo 904-900-2197_9045551212 foo
foo FooBar_AL_2055551212 foo
foo 904-555-1212_9045551212 foo
Maintenance Notification 7725551212 Phone FooBaz_at_St_Lucie_West_FL_7725551212 liveCallback
1@FooFoo_at_Summerwood_TX_2814581010|sg(14)
users/Jacksonville_FL/MG|m
Office Notification 5105551212 Phone Los_Angeles_CA
Maintenance LogIn
Courtesy Transfer 8665551212
SIP/trunk_2_abc/18669302777
1@Popes_Hat_NC_7045551212|sg(14)
users/Frogs_Feet_Washington_DC_2025551212/MG|m
users/Mt_Food_Portland_OR_5035551212/INTRO|m
SIP/trunk_2_icc/18669302777
3@Jelly_Bean_NC_8285551212|sg(14)
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);