package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:"(\\u[a-zA-Z0-9]{4}|\\[^u]|[^\\"])*"(\s*:)?|\b(true|false|null)\b|-?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?|([\{\}\[\]]))`)
var str = `{
"a": 1,
"b": "foo",
"c": [
false,
"false",
null,
"null",
{
"d": {
"e": 130000,
"f": "1.3e5"
}
}
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}