re = /(?:"(\\u[a-zA-Z0-9]{4}|\\[^u]|[^\\"])*"(\s*:)?|\b(true|false|null)\b|-?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?|([\{\}\[\]]))/
str = '{
"a": 1,
"b": "foo",
"c": [
false,
"false",
null,
"null",
{
"d": {
"e": 130000,
"f": "1.3e5"
}
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end