$re = '~(\+44)(\d{4})~m';
$str = '+442070320811
2070 320811';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);