#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)"
Local $sString = "" & @CRLF & _
"return scheduler" & @CRLF & _
"" & @CRLF & _
"end)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"package.preload['packages.utils.toluaEx'] = (function (...)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")