using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"package\.preload\[\s*(?P<qute>['\""])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)";
string input = @"
return scheduler
end)
package.preload['packages.utils.toluaEx'] = (function (...)
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}