import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "package\\.preload\\[\\s*(?P<qute>['\\\"])(\\w+(?:\\.\\w+)*)(?P=qute)\\s*\\]\\s*=\\s*\\(\\s*function\\s*\\(\\s*\\.{3}\\s*\\)";
final String string = "\n"
+ "return scheduler\n\n"
+ "end)\n\n\n"
+ "package.preload['packages.utils.toluaEx'] = (function (...)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}