$re = '/package\.preload\[\s*(?P<qute>[\'\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)/';
$str = '
return scheduler
end)
package.preload[\'packages.utils.toluaEx\'] = (function (...)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);