use strict;
my $str = 'Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com';
my $regex = qr/[\xE8-\xEB](?!.*;)/p;
my $subst = 'e';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";