# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\xE8-\xEB](?!.*;)"
test_str = ("Joëlle;Dupont;123456;joëlle.dupont@mail.com\n"
"Alex;Léger;134234;alex.léger@mail.com")
subst = "e"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.