// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\|\|([^\n]+?)\|\|").unwrap();
let string = "This is some ||spoiler text|| that we want to avoid people from seeing, otherwise they may see spoilers about ||the new movie that came out yesterday||.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}