// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(((((#)|())(([ \t\n]+|()))([a-zA-Z0-9]+)([ \t\n]+))|())((([ \t\n]+|()))((move|mult)|([a-z]+)))((([ \t\n]+|()))(:))((([ \t\n]+|()))([a-zA-Z0-9,&\* \t\"\n\[\]]+))(;))|((([ \t\n]+|()))((save|end)|([a-z]+))(([ \t\n]+|()))(;))"#).unwrap();
let string = "
{
stream: gogo;
move: some, reg1;
#jix mult: &num, reg2;
push: reg2;
sus : 0x20;
add : him, her;
#goto
jump: loop;
dec : him, *reg2;
#get
add : onu, buna;
jump: goto;
#mydear move: \"moses\", rgb[8];
save ;
end ;
}
{
move: mos, reg1;
mult: &num, reg2;
push: reg2;
int : 0x20;
#lab
add : him, her;
jump: loop;
#mos
dec: him, *reg2;
#inst
add: onu, buna;
jump: lab;
save;
end;
}
{
inc: moses, to;
#io
push: him;
#kim
jump: frame;
}
okbro () {
dec: him, beat;
#his
push: him;
jump: main;
ret; }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}